Vitpilen quickshifter issues


  • This topic has 27 replies, 11 voices, and was last updated 1 month ago by AvatarHawwk.
Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
    Posts
  • #26565
    Avatarjaysgarage
    Participant

    Unfortunately it won’t shift at all, even with what seems like excessive force.  If I use the clutch it plunks right into gear with no issues.  Down shift/auto blip works fine though…

    #26566
    Max KoolMax Kool
    Participant

    How does it upshift without clutch but still closing the throttle momentarily?

    #26567
    Avatarjaysgarage
    Participant

    An upshift with no clutch, but a brief roll off throttle shifts perfectly fine.  If you then try to do the same while maintaining throttle or accelerating it won’t shift at all without the clutch.

    #26568
    Max KoolMax Kool
    Participant

    So it’s clearly the quickshifter, and not the gearbox.

    #26569
    mitchotmitchot
    Participant

    Agreed, sounds like an issue with the quickshifter. On my ride into work this morning I held a nice constant throttle and shifted up easily.

    #26571
    Avatarjaysgarage
    Participant

    Sounds like I need to get it looked at when I do the first service.

    #27269
    Avatarjaysgarage
    Participant

    Thanks for the response.  Unfortunately it won’t shift up at all with the quick shifter, but it will quick shift down.   When shifting normally with the clutch it works fine…

    #27270
    Avatarjecnak
    Participant

    I had same problem with quickshifter after new firmware update installed by dealer. New firmware with patch solved this.

    #27271
    Avatarjaysgarage
    Participant

    Good to hear

    #27322
    Avatarelfix
    Participant

    Mine (at 300 miles) will shift up and down but it feels like you are just jamming it into the next gear and takes too much effort to be worth doing. I have lots of experience with clutches shifting by slightly unloading the gearbox on many other machines and the Vit by comparison seems like the quick shift isn’t doing anything at all.

     

    The gearbox shifts with ease and precision if you use the clutch, and also easily if you roll off the throttle a little on and upshift and speed match on a downshift, so I think my quick shifter either has yet to be enabled (some maintain this is a part of the 600 mile service) or needs a firmware patch.

     

    Will report back after the 600 mile service.

    #27658
    Avatarjaysgarage
    Participant

    I’m interested to see if the first service unlocks it or if it’s an update to the computer. I’m waiting on warm weather to get some more miles.

    #27679
    AvatarSH
    Participant

    Had this issue after having the display changed. Husky tech had to get KTM in Austria to reset the entire system over the internet.

    #28659
    AvatarHawwk
    Participant

    Were you able to get your quickshifter to work?
    I had the exact same problem as you did – Bought a 2019 Vitpilen yesterday online and without a test drive due to Corona-Lockdown. On my first ride I noticed that the quickshifter wasn’t working at all, I was only able to shift without the clutch by unloading the engine.
    I went to the dealer first thing today and just told them to update the gearbox software – the quickshifter started working after that.

    So like others have said before, that would be your best bet.

Viewing 13 posts - 16 through 28 (of 28 total)
  • You must be logged in to reply to this topic.