Traction control doesn’t want to turn off


Viewing 15 posts - 1 through 15 (of 47 total)
  • Author
    Posts
  • #27286
    Nostalgiavitpilen
    Participant

    So I’ve just got my stock 701 and I hold down the unmarked button while the engine is running and no matter how long I hold it for the tc doesn’t switch off. Is there some trick I’m missing.

     

    The abs turn off sequence works a treat I just can’t get the tc off

    #27287
    Nostalgiavitpilen
    Participant

    Also just checked and the tc light doesn’t go in when you flick the ignition switch on

    #27291
    Anonymous

    Hi

    if it’s a new bike there may be a block on TC off before you’ve done the run-in mileage and get the first service done.

    #27293
    Nostalgiavitpilen
    Participant

    Ahh OK so it’s not specifically that somethings wrong. It’s done 3k miles and had a service but I’m guessing they haven’t turned that off… I’ll get in touch with husky and see if they can switch it off

    Thank you

    #27297
    Nostalgiavitpilen
    Participant

    I called husky and they want to book it in to plug it in. They don’t think it would be that it’s not enabled because the light would still display on start up. Any other ideas or similar problems would be welcome

    #27311
    Max Kool
    Participant

    I’m surprised. I bought my bike at 580 miles. The previous owner already set the shifting rpms right before I got it, he did not have a dealer look at it. I did the 600 mile service myself. All good. I can turn both tc and abs off… (and the quickshifter also works as it should).

     

    Wierd

    #27312
    Nostalgiavitpilen
    Participant

    Yeah it seems like somethings up… My tc light doesn’t show when the ignition is clicked on… Also doesn’t show when you spin up the back wheel and the tc kicks in…. Its working but not showing lights…. Also doesn’t say jeep pressing or anything like that when you try to turn it off….

     

    #27321
    elfix
    Participant

    I thought you had to hold down the top button at the same time as the mystery button to turn off the TC.

    But to be honest, I only have 300 miles on mine and haven’t tried it yet.

    #27323
    Nostalgiavitpilen
    Participant

    <p style=”text-align: left;”>That’s to switch off the abs</p>

    #27324
    Max Kool
    Participant

    To clarify:

    Center button & bottom button: ABS off
    Bottom button alone: TC off

    #27325
    Nostalgiavitpilen
    Participant

    Top and bottom button abs bottom button tc

    #27397
    Max Kool
    Participant

    Yeah sorry, I stand corrected.

    #27483
    TheRock3tBunny
    Participant

    Has this been figured out by the OP? I just got a new 701 3 days ago and same issue.. ABS will turn off, but the TC does not light up on start up or say anything no matter how long I hold.

    Also for the ABS off, does everybody’s say “not legal” and the ABS light stays on during this?

    #27488
    Nostalgiavitpilen
    Participant

    Yeah it says not legal on mine. Its just because to be euro 5 they have to have abs fitted… And no not yet its going to the dealer on Monday to be looked at. They have tried to convince me that its totally normal as soon as I mentioned the warrenty word.. I’ll post an update when I get one….

     

    The fact yours is brand new and does it would make me think it could be a first service enable thing

    #27489
    Nostalgiavitpilen
    Participant

    Also can you set your shift light… Have a look in the manual for how but basically that function doesn’t work on mine either

Viewing 15 posts - 1 through 15 (of 47 total)
  • You must be logged in to reply to this topic.