Oil leak at 3600mi


Tagged: ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29099
    ed619
    Participant

    After about 3000 miles of awesome rides and adventures my bike has sprung a mysterious leak.

    On the way to work today (15mi drive) I smelled something burning as I slowed down and pulled into my office parking lot. Bikes currently sitting outside with a piece of cardboard underneath 🙁 It’s not dripping oil but there was certainly some sort of leakage.

    Oil level is still between the min and max line and brake fluid looks filled as can be.

    Hoping this is nothing extreme or major. Still under warranty. She’s going in tomorrow.

    https://i.imgur.com/z9a5vfw.png

     

    #29147
    Rider_Kim
    Participant

    That seems like coolant, not oil. Wish not a big issue.

    #30156
    B.I.Savage
    Participant

    There is that thing screwed into the head there with the cable bolted on it just above the radiator hose at the top left of your second pic (oil pressure sensor?) Is the leak coming from there? If so that’s a 2 second fix and not so tragic.

    #34048
    Jgrosario20
    Participant

    I have the same leak, did the shop say what they replaced?

    #34193
    Jgrosario20
    Participant

    I had the same leak, my case it was the oil pressure sensor. It can be either the sensor itself or its o-ring. The sensor comes with its own new o-ring, I recommend just swapping it out since you are already going through the trouble. It’s a 15min fix, nothing mayor. Cost less than $15.00 for the sensor and you need a 13/16 long socket to get it out. Hope this helped anyone that needs the information.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.