Low Oil Pressure Won\'t Go Away


Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #5297
    AvatarAJ-Furd
    Participant

    I’ve had my 2018 Vitpilen for a few months now, finally hit 1000km and had it serviced. I told the service department that my Low Oil Pressure light isn’t going away, even after filling it to the correct amount. They ran it through the computer and weren’t getting any readings about the low oil pressure. The light didn’t even come on when they fired it up and had it running.

    I drove it back home after and low and behold, the light came back on. Has anyone else had this problem and know what is going on or is my bike a rare anomaly?

    #5308
    AvatarG13kizz
    Participant

    Im having the same problem with mine and dealer cant figure it out theyve had my bike for a month

    #5314
    AvatarAJ-Furd
    Participant

    I think it’s still ok to ride but I’m keeping an eye on my oil level constantly and it looks fine. The guys who worked on my bike gave it back the same day and they’re currently trying to figure out the issue. No word yet.

    #5989
    Avatarpioneeringsince1903
    Participant

    This issue started two days ago on 7/15/2019.

    I’m on a 2017 Svartpilen with under 4,000 miles on the odometer. I bought the bike late in 2018 from GP Motorcycles in San Diego, CA. Did the first maintenance at Munroe Motors in San Fransisco, CA. No issues were flagged at the first maintenance.

    Will update as things develop.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.