Kill Switch


Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1110
    AvatarScott Emm
    Participant

    Am I the only one bumping this?  Luckily, only as I seem to slow for a red light or stop sign.  I have switch it dead a few times.  I hope it doesn’t work at higher speeds!  Its super loose and easy to tap.

     

    Am I alone?

    #1136
    MotoIncognitoMotoIncognito
    Participant

    No, I have the opposite problem. I keep accidentally turning on my high beams somehow.

    #1196
    AvatarTravis
    Participant

    I somehow keep hitting the high beams as well

    #1199
    AvatarScott Emm
    Participant

    hahah I havent yet I dont think.  When I go to my bike after work I will die laughing if the high beams are on.

    #2459
    Avatarkylemac
    Participant

    I can’t seem to cancel the turn signal without honking at whoever is around…

    #2461
    AvatarMacloven
    Participant

    Constantly bumping on the high beams.

    #2468
    ThemSheepsThemSheeps
    Participant

    I am well versed in bumping the kill switch… 😜and since replacing the clutch lever I can only start the bike in neutral.

    Can’t wait to get the clutch sensor working again!

    #2470
    AvatarMacloven
    Participant

    the ebay laser engraved levers I bought had the little groove for the clutch ignition switch much to my relief and seems to work fine.

    #2478
    MidnaiteMidnaite
    Participant

    yes, I noticed that.

    I had some trouble taking apart the OEM clutch level cause of the sensor. I didn’t know i had the remove it before.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.