Forum shop issue


Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5655
    AvatarErnorama
    Participant

    hi everyone, I’ve made an order to the forum’s shop. It was on May 14. First days of June they sent me an email that I will receive an automatic mail with the shipping ID. Never received it. June 23 and still no news. Sent 3 more emails to receive the tracking number. Nothing. anyone else on the same situation? Does anybody received items from this shop? Thanks and sorry for my bad English

    #5661
    AvatarAnonymous

    I haven’t ordered anything from the site because they do not ship to Canada.

    Questions:

    1. Are you in the U.S.?

    2. Has your credit card been debited (have they taken the funds)?

    Good luck, regardless.

    #5667
    rlaruerlarue
    Participant

    When I made an order I wasn’t sent a tracking number automatically, but they provided one after I reached out and shipping was pretty quick.  Which item did you order? Jamin is the one that responded so maybe try them with your order number: jamin@vitpilenforum.com

    #5672
    QwandreeQwandree
    Moderator

    I’ve ordered stuff from them for my 701. No issues, they have always been responsive. A few times items have been back ordered from husky and takes a bit, no different from any other retailer.

     

    I try to support them whenever possible since they run this forum (with no ads) and it’s a great resource for this community. Fun fact, the site owner rides a svart 401.

    #5674
    AvatarErnorama
    Participant

    They, answered and also send the tracking id. Was an internal error of my courier company. My courier Didn’t recieved the tracking id, until past Thursday. Thanks to all. I think that the problem is solved!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.